RouterOS利用aliyun的API接口实现DDNS动态解析

首先区分:动态解析,内网穿透的区别

动态解析:动态域名解析服务,是将用户的动态IP地址映射到一个固定的域名解析服务上,用户每次连接网络的时候,客户端程序就会通过信息传递把该主机的动态IP地址传送给位于服务商主机上的服务器程序,服务程序负责提供DNS服务并实现动态域名解析。就是说DDNS捕获用户每次变化的IP地址,然后将其与域名相对应,这样域名就可以始终解析到非固定IP的服务器上,互联网用户通过本地的域名服务器获得网站域名的IP地址,从而可以访问网站的服务。

内网穿透:也即 NAT 穿透传统的NAT技术是通过将专用的网络地址(如企业内部网Internet)转换为公用地址(如互联网Internet),从而对外隐藏了内部管理的IP地址。这样,通过在内部使用非注册的IP地址,并将它们转换为一小部分外部注册的IP地址,从而减少了IP地址注册的费用以及节省了目前越来越缺乏的地址空间。

本文主要讲解如何借助阿里云aliyun的云解析API接口来实现RouterOS(以下简称ROS)的DDNS动态解析。

RouterOS利用aliyun的API接口实现DDNS动态解析

请点击下方连接移步查看

需要注意的是:

  1. 代码一共两个,一个在阿里云官网设置,一个在本地ROS软路由里设置
  2. 建议先看原作者网站,然后在看csdn博客里的设置。
  3. 关键提示(更改的地方我做标记)剩下不加粗的不要更改

    {

    “Version”: “1”,

    “Statement”: [

    {

    “Action”: [

    “alidns:AddDomainRecord”,

    “alidns:DescribeDomainRecords”,

    “alidns:UpdateDomainRecord”

    ],

    “Resource”: “acs:alidns:*:*:domain/myxzy.com改成你的域名“,

    “Effect”: “Allow”

    }

    ]

    }

  4. 关键提示(更改的地方我做标记)剩下不加粗的不要更改

    #aliyun Access Key

    :local id “AccessKeyId

    :local secret “AccessKeySecret

    #domain

    :local domain “myxzy.com更改成自己的域名

    :local record “www按需填写也可全删除

    #PPPoE-out

    :local pppoe “pppoe-out1 一定是你可以获得外网IP的那个拨号线路

    :local ipaddr [/ip address get [/ip address find interface=$pppoe] address]

    :set ipaddr [:pick $ipaddr 0 ([len $ipaddr] -3)]

    :global aliip

    :if ($ipaddr != $aliip) do={

    :local result [/tool fetch url=”http://u.myxzy.com/alidns/\?id=$id&secret=$secret&domain=$domain&record=$record&ip=$ipaddr” as-value output=user];

    :if ($result->”status” = “finished”) do={

    :if ($result->”data” = “0”) do={

    :set aliip $ipaddr

    :log info “alidns update ok”;

    } else={

    :log info “alidns update error”;

    }

    }

    }

alidns-api-php脚本源码

Github:https://github.com/myxzy/alidns-api-php

原创文章,作者:bi4jgm,如若转载,请注明出处:https://showdoi.com/461.html

发表评论

您的电子邮箱地址不会被公开。 必填项已用*标注